To access eSkill, all you need is a computer with an Internet connection.

  • PC-based test takers: Windows® XP SP3, 2003 Server, 2008 Server, Vista,7 SP1, 8.1, 10, or Linux.
  • Macintosh®-based test takers: Mac OS® X 10.3.9 (Panther®), or newer.

The eSkill web application is compatible with the following browsers:

  • Internet Explorer (Version 9 or later)
  • Edge (Version 20 or later)
  • Firefox (Version 10 or later)
  • Chrome (Version 5 or later; PC only)
  • Safari 8 (Version 8 or later; Mac only).

Download one of these eSkill-compatible browsers at no charge:

A hardware system with Pentium III, 700 MHz, and 512MB RAM is the suggested minimum. Using eSkill requires a minimum 56 kbps Internet connection.

You need to have JavaScript installed and running on your web browser in order to take some assessments.

For questions that include audio files, you need to have Adobe Flash Player 10 or later installed, or use a compatible browser that offers support for HTML5. The following browsers support HTML5:

  • Internet Explorer (Version 9 or later)
  • Edge (Version 20 or later)
  • Firefox (Version 26 or later)
  • Chrome (Version 5 or later; PC only)
  • Safari 8 (Version 8 or later; Mac only).

If you need to install Adobe Flash Player, download the application and follow the instructions. If you are having trouble with your Adobe Flash Player, please click on the following links.

If you are having trouble with your Adobe Flash Player, check the following links for a solution.

Comments are closed here.